Logo of the Elmira & District Rod and Gun Club. Two outlines of male deer flank a badge which contains the sihoulette of a duck flying above a fish that is jumping out of a stream in a marsh.
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Help

Fob Issues

Problem

My fob doesn't light up or change colour when I insert it in to a station.

Cause

Your fob is most likely not charged.

Solution

Using a USB cable connected to a port on a computer or a USB charging brick, connect your fob with the included charging adapter. The fob should flash red while it's charging, and once it's complete, hold a steady green light.

Problem

My fob turns red but not green when docking or at a station.

Cause

Your fob is most likely not updated.

Solution

You can visit one of the two fob update stations located at the clubhose - one inside the main doors, the other directly outside the main doors. Insert the key and wait for the light to turn green.

Newsletter Issues

Problem

I am not receiving a newsletter.

Cause

There are many reasons that you may not be receiving a newsletter, sometimes these are out of our control.

Solution

All members are asked to provide their email address during registration/renewal. If you have not provided your email address, please contact membership@elmirarodandgun.org to update your membership details.

If your information is correct at the time you registered/renewed, you can attempt one of the following steps:

  • Check your spam folder for any emails from the club. If they are ending up in your Spam Folder, make sure to mark them as "Not Spam".
  • Add the elmirarodandgun.org and e.elmirarodandgun.org domains to your email provider's Safe Sender/Whitelist.
  • Contact webmaster@elmirarodandgun.org with an alternate email address we can use.
  • Email addresses from providers such as Hotmail are strongly discouraged, as they heavily block our domain even after we've done a lot of work to fix these problems.